今天在使用flask-login添加用户认证的时候服务器出现了报错

[

0](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/0-300x140.jpg)](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/0.jpg) [![1](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/1.jpg)
0](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/0-300x140.jpg)](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/0.jpg) [![1](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/1.jpg)

而我的 base.html是这样写的:

[

2](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/2-300x56.jpg)](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/2.jpg) 去看官方文档吧,选择对应版本的文档(我这里是0.3.1): [![3](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/3-300x78.jpg)](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/3.jpg) 再看看其前面的版本是不是这样定义的: [![4](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/4-300x68.jpg)
2](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/2-300x56.jpg)](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/2.jpg) 去看官方文档吧,选择对应版本的文档(我这里是0.3.1): [![3](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/3-300x78.jpg)](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/3.jpg) 再看看其前面的版本是不是这样定义的: [![4](https://qcloud.coding.net/u/guomaoqiu/p/guomaoqiu/git/raw/master/uploads/2016/06/4-300x68.jpg)

看吧 版本问题造成。